using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([А-Я])[а-я]+\s+([А-Я])[а-я]+\s+([А-Я])[а-я]+";
string substitution = @"\1.\2.\3.";
string input = @"Физофрениев Изофрений Офрениевич";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}