import Foundation
let pattern = #"([А-Я])[а-я]+\s+([А-Я])[а-я]+\s+([А-Я])[а-я]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Физофрениев Изофрений Офрениевич"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1.\2.\3."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)