package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([А-Я])[а-я]+\s+([А-Я])[а-я]+\s+([А-Я])[а-я]+`)
var str = `Физофрениев Изофрений Офрениевич`
var substitution = "\1.\2.\3."
fmt.Println(re.ReplaceAllString(str, substitution))
}