import re
regex = re.compile(r"([А-Я])[а-я]+\s+([А-Я])[а-я]+\s+([А-Я])[а-я]+", flags=re.MULTILINE)
test_str = "Физофрениев Изофрений Офрениевич"
subst = "\\1.\\2.\\3."
result = regex.sub(subst, test_str)
if result:
print(result)