#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/\d+-\d"
Local $sString = "ILLD/ELKJS/00000000/ELKJS/FHSH" & @CRLF & _
"ILLD/EFECTE/0116988-7-002/ADFA/ADFG" & @CRLF & _
"IIODK/1573230-0/2216755-7/" & @CRLF & _
"IIODK/1573230-0/2216755-700/WRITE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")