import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\d+-\\d";
final String string = "ILLD/ELKJS/00000000/ELKJS/FHSH\n"
+ "ILLD/EFECTE/0116988-7-002/ADFA/ADFG\n"
+ "IIODK/1573230-0/2216755-7/\n"
+ "IIODK/1573230-0/2216755-700/WRITE";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}