re = /\/\d+-\d/
str = 'ILLD/ELKJS/00000000/ELKJS/FHSH
ILLD/EFECTE/0116988-7-002/ADFA/ADFG
IIODK/1573230-0/2216755-7/
IIODK/1573230-0/2216755-700/WRITE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end