package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/\d+-\d`)
var str = `ILLD/ELKJS/00000000/ELKJS/FHSH
ILLD/EFECTE/0116988-7-002/ADFA/ADFG
IIODK/1573230-0/2216755-7/
IIODK/1573230-0/2216755-700/WRITE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}