using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[([^]]+)\](.+)$";
string input = @"[AA] abcd 1234 !@#$ _+{}[]:""
blah blah
[abc-def] this is also value.
[BB]abcd defg
[CC] (can null)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}