re = /^\[([^]]+)\](.+)$/m
str = '[AA] abcd 1234 !@#$ _+{}[]:"
blah blah
[abc-def] this is also value.
[BB]abcd defg
[CC] (can null)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end