package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[([^]]+)\](.+)$`)
var str = `[AA] abcd 1234 !@#$ _+{}[]:"
blah blah
[abc-def] this is also value.
[BB]abcd defg
[CC] (can null)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}