// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[([^]]+)\](.+)$").unwrap();
let string = "[AA] abcd 1234 !@#$ _+{}[]:\"
blah blah
[abc-def] this is also value.
[BB]abcd defg
[CC] (can null)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}