# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^|[^a-zA-Z0-9$#])\Qtext\E(?=$|[^a-zA-Z0-9])//gm;t' <<< "My text is very beautyfull. Yours $text is very bautyfull. Their #text, is very beautyfull"