import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|[^a-zA-Z0-9$#])\\Qtext\\E(?=$|[^a-zA-Z0-9])";
final String string = "My text is very beautyfull. Yours $text is very bautyfull. Their #text, is very beautyfull";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}