$re = '/(?<=^|[^a-zA-Z0-9$#])\Qtext\E(?=$|[^a-zA-Z0-9])/m';
$str = 'My text is very beautyfull. Yours $text is very bautyfull. Their #text, is very beautyfull';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;