const regex = /(?<=^|[^a-zA-Z0-9$#])\Qtext\E(?=$|[^a-zA-Z0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|[^a-zA-Z0-9$#])\\Qtext\\E(?=$|[^a-zA-Z0-9])', 'gm')
const str = `My text is very beautyfull. Yours \$text is very bautyfull. Their #text, is very beautyfull`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);