# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\s+)|(?<=[^\w\s])(?=\w)|(?<=\w)(?=[^\w\s])/\n/gm;t' <<< "hello world(12)"