import re
regex = re.compile(r"(?:\s+)|(?<=[^\w\s])(?=\w)|(?<=\w)(?=[^\w\s])", flags=re.MULTILINE)
test_str = "hello world(12)"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)