$re = '/(?:\s+)|(?<=[^\w\s])(?=\w)|(?<=\w)(?=[^\w\s])/m';
$str = 'hello world(12)';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;