re = /(?:\s+)|(?<=[^\w\s])(?=\w)|(?<=\w)(?=[^\w\s])/m
str = 'hello world(12)'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result