#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^[^-]+)-([^-]+)-"
Local $sString = "12055371-1-Florence - BW Letter of Intent HB Comments 9-4-14-2.DOCX" & @CRLF & _
"12057668-2-EB-DUE-M- SBuxbaum FHA Benefit Plans-2.DOCX" & @CRLF & _
"12058210-1-Redline Letter of Intent-2.PDF" & @CRLF & _
"12058029-3-Florence Hospital--Order Establishing Bid Procedures-HB 9-23-14-2.DOCX " & @CRLF & _
"12058020-10-Florence - BW Letter of Intent 10,10,14 Revisions-2.DOCX "
Local $sSubst = "\1|\2|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)