$re = '/(^[^-]+)-([^-]+)-/m';
$str = '12055371-1-Florence - BW Letter of Intent HB Comments 9-4-14-2.DOCX
12057668-2-EB-DUE-M- SBuxbaum FHA Benefit Plans-2.DOCX
12058210-1-Redline Letter of Intent-2.PDF
12058029-3-Florence Hospital--Order Establishing Bid Procedures-HB 9-23-14-2.DOCX
12058020-10-Florence - BW Letter of Intent 10,10,14 Revisions-2.DOCX ';
$subst = "\1|\2|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;