# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^[^-]+)-([^-]+)-"
test_str = ("12055371-1-Florence - BW Letter of Intent HB Comments 9-4-14-2.DOCX\n"
"12057668-2-EB-DUE-M- SBuxbaum FHA Benefit Plans-2.DOCX\n"
"12058210-1-Redline Letter of Intent-2.PDF\n"
"12058029-3-Florence Hospital--Order Establishing Bid Procedures-HB 9-23-14-2.DOCX \n"
"12058020-10-Florence - BW Letter of Intent 10,10,14 Revisions-2.DOCX ")
subst = "\\1|\\2|"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.