import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[^-]+)-([^-]+)-";
final String string = "12055371-1-Florence - BW Letter of Intent HB Comments 9-4-14-2.DOCX\n"
+ "12057668-2-EB-DUE-M- SBuxbaum FHA Benefit Plans-2.DOCX\n"
+ "12058210-1-Redline Letter of Intent-2.PDF\n"
+ "12058029-3-Florence Hospital--Order Establishing Bid Procedures-HB 9-23-14-2.DOCX \n"
+ "12058020-10-Florence - BW Letter of Intent 10,10,14 Revisions-2.DOCX ";
final String subst = "\\1|\\2|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}