#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[+-]?((\d+\.?\d*)|(\.\d+))"
Local $sString = "+123.13" & @CRLF & _
"-0.464" & @CRLF & _
"13115313" & @CRLF & _
"000013134" & @CRLF & _
"123..." & @CRLF & _
"10..12113"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")