// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[+-]?((\d+\.?\d*)|(\.\d+))").unwrap();
let string = "+123.13
-0.464
13115313
000013134
123...
10..12113";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}