import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[+-]?((\\d+\\.?\\d*)|(\\.\\d+))";
final String string = "+123.13\n"
+ "-0.464\n"
+ "13115313\n"
+ "000013134\n"
+ "123...\n"
+ "10..12113";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}