const regex = /^$|^[а-яёА-ЯЁ\s]+$|^[а-яёА-ЯЁ\s]+(?=[,;])[,;][а-яёА-ЯЁ\s]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^$|^[а-яёА-ЯЁ\\s]+$|^[а-яёА-ЯЁ\\s]+(?=[,;])[,;][а-яёА-ЯЁ\\s]+$', 'gm')
const str = `Иванов Иван Иванович
Иванов Иван, Петров Петр
Иванов Иван; Петров Петр
Иванов Иван; Петров Петр; Иванов Иван
Иванов И. А.
Иванов Иван, Петров Петр, Сидоров Сидор
Иванов Иван; Петров Петр; Иванов Иван
Иванов Иван; Петров Петр;
Иванов Иван; Петров Петр
Иванов Иван; Петров
б б б, ыва ываыв ыва`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}