$re = '/^$|^[а-яёА-ЯЁ\s]+$|^[а-яёА-ЯЁ\s]+(?=[,;])[,;][а-яёА-ЯЁ\s]+$/m';
$str = 'Иванов Иван Иванович
Иванов Иван, Петров Петр
Иванов Иван; Петров Петр
Иванов Иван; Петров Петр; Иванов Иван
Иванов И. А.
Иванов Иван, Петров Петр, Сидоров Сидор
Иванов Иван; Петров Петр; Иванов Иван
Иванов Иван; Петров Петр;
Иванов Иван; Петров Петр
Иванов Иван; Петров
б б б, ыва ываыв ыва';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);