re = /^$|^[а-яёА-ЯЁ\s]+$|^[а-яёА-ЯЁ\s]+(?=[,;])[,;][а-яёА-ЯЁ\s]+$/m
str = 'Иванов Иван Иванович
Иванов Иван, Петров Петр
Иванов Иван; Петров Петр
Иванов Иван; Петров Петр; Иванов Иван
Иванов И. А.
Иванов Иван, Петров Петр, Сидоров Сидор
Иванов Иван; Петров Петр; Иванов Иван
Иванов Иван; Петров Петр;
Иванов Иван; Петров Петр
Иванов Иван; Петров
б б б, ыва ываыв ыва'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end