using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^LH..42UHS.*$";
string input = @"LH7542UHS-B3
XU2492HSU-B1
XUB2792QSU-W1
TE6504MIS-B2AG";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}