$re = '/^LH..42UHS.*$/m';
$str = 'LH7542UHS-B3
XU2492HSU-B1
XUB2792QSU-W1
TE6504MIS-B2AG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);