const regex = /^LH..42UHS.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^LH..42UHS.*$', 'gm')
const str = `LH7542UHS-B3
XU2492HSU-B1
XUB2792QSU-W1
TE6504MIS-B2AG`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}