package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^LH..42UHS.*$`)
var str = `LH7542UHS-B3
XU2492HSU-B1
XUB2792QSU-W1
TE6504MIS-B2AG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}