# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\\/(dp|product)\\/ | .*page//;t' <<< "http://www.amazon.in/s/lp_6563520031_pg_2?rh=n%3A5866078031%2Cn%3A%215866079031%2Cn%3A6563520031&page=2s&ie=UTF8&qid=1446802571"