re = /.*\/(dp|product)\/ | .*page/
str = 'http://www.amazon.in/s/lp_6563520031_pg_2?rh=n%3A5866078031%2Cn%3A%215866079031%2Cn%3A6563520031&page=2s&ie=UTF8&qid=1446802571'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result