const regex = /.*\/(dp|product)\/ | .*page/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\/(dp|product)\\\/ | .*page', '')
const str = `http://www.amazon.in/s/lp_6563520031_pg_2?rh=n%3A5866078031%2Cn%3A%215866079031%2Cn%3A6563520031&page=2s&ie=UTF8&qid=1446802571`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);