#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\\(.*\s\b[^\\]+?)\\"
Local $sString = "cat "food" | c:\Program Files\nodejs\node.exe" & @CRLF & _
"" & @CRLF & _
"c:\Program Files\nodejs\node.exe" & @CRLF & _
"" & @CRLF & _
"cat "c:\Program Files\nodejs\node.exe" | pipe | c:\apps and stuff\node.exe"
Local $sSubst = "\\"$1"\\"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)