import Foundation
let pattern = #"\\(.*\s\b[^\\]+?)\\"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
cat "food" | c:\Program Files\nodejs\node.exe
c:\Program Files\nodejs\node.exe
cat "c:\Program Files\nodejs\node.exe" | pipe | c:\apps and stuff\node.exe
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\"$1"\\"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)