package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\(.*\s\b[^\\]+?)\\`)
var str = `cat "food" | c:\Program Files\nodejs\node.exe
c:\Program Files\nodejs\node.exe
cat "c:\Program Files\nodejs\node.exe" | pipe | c:\apps and stuff\node.exe`
var substitution = "\\"$1"\\"
fmt.Println(re.ReplaceAllString(str, substitution))
}