$re = '/\\\\(.*\s\b[^\\\\]+?)\\\\/';
$str = 'cat "food" | c:\\Program Files\\nodejs\\node.exe
c:\\Program Files\\nodejs\\node.exe
cat "c:\\Program Files\\nodejs\\node.exe" | pipe | c:\\apps and stuff\\node.exe';
$subst = "\\\"$1\"\\";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;