package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi).+(?:flag|tmp)$`)
var str = `abc
abc.flag
abc.tmp
test
test.flag
test.tmp
dontexclude.exe
doge.gif
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}