import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+(?:flag|tmp)$";
final String string = "abc\n"
+ "abc.flag\n"
+ "abc.tmp\n"
+ "test\n"
+ "test.flag\n"
+ "test.tmp\n"
+ "dontexclude.exe\n"
+ "doge.gif\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}