$re = '/.+(?:flag|tmp)$/mi';
$str = 'abc
abc.flag
abc.tmp
test
test.flag
test.tmp
dontexclude.exe
doge.gif
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);