re = /.+(?:flag|tmp)$/mi
str = 'abc
abc.flag
abc.tmp
test
test.flag
test.tmp
dontexclude.exe
doge.gif
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end