$re = '/^(Test|Sample)(?!.*(Hello|World))(?=$|.*(Stuff|Other)).*/m';
$str = 'Test
Test Good
Sample Stuff
Test Hello
Sample World
Test Hello Stuff
Sample Good World
Test Other
Test Other Stuff
Sample Other World
Test Other Stuff Other
The following strings would be';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);