re = /^(Test|Sample)(?!.*(Hello|World))(?=$|.*(Stuff|Other)).*/m
str = 'Test
Test Good
Sample Stuff
Test Hello
Sample World
Test Hello Stuff
Sample Good World
Test Other
Test Other Stuff
Sample Other World
Test Other Stuff Other
The following strings would be'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end