#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<DATA>*<\DATA>"
Local $sString = "<DATA><Status>E</Status><StatusCode>501</StatusCode><Description>Duplicate Integrator Trasaction ID</Description><CasinoID>0</CasinoID><OperatorID>0</OperatorID><UserName>0</UserName><UserPWD>0</UserPWD><UserID>0</UserID><UserType></UserType><Amount>0</Amount><Currency>XXX</Currency><TransactionType></TransactionType><TransactionID>0000000001</TransactionID></DATA>INSERT INTO STG.dbo.CR_INTEGRATOR_REQUESTS (IntegratorTrnID, OperatorID) OUTPUT(INSERTED.ID) VALUES (0000000001, 75281)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")