package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<DATA>*<\DATA>`)
var str = `<DATA><Status>E</Status><StatusCode>501</StatusCode><Description>Duplicate Integrator Trasaction ID</Description><CasinoID>0</CasinoID><OperatorID>0</OperatorID><UserName>0</UserName><UserPWD>0</UserPWD><UserID>0</UserID><UserType></UserType><Amount>0</Amount><Currency>XXX</Currency><TransactionType></TransactionType><TransactionID>0000000001</TransactionID></DATA>INSERT INTO STG.dbo.CR_INTEGRATOR_REQUESTS (IntegratorTrnID, OperatorID) OUTPUT(INSERTED.ID) VALUES (0000000001, 75281)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}