// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<DATA>*<\DATA>").unwrap();
let string = "<DATA><Status>E</Status><StatusCode>501</StatusCode><Description>Duplicate Integrator Trasaction ID</Description><CasinoID>0</CasinoID><OperatorID>0</OperatorID><UserName>0</UserName><UserPWD>0</UserPWD><UserID>0</UserID><UserType></UserType><Amount>0</Amount><Currency>XXX</Currency><TransactionType></TransactionType><TransactionID>0000000001</TransactionID></DATA>INSERT INTO STG.dbo.CR_INTEGRATOR_REQUESTS (IntegratorTrnID, OperatorID) OUTPUT(INSERTED.ID) VALUES (0000000001, 75281)";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}